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In this tutorial you will learn the basics of Geographic Imager by working with a series of tutorial exercises. All of the 
sub-folders of files, images, data and scripts for the tutorial exercises can be found in the following locations:

Windows XP
C:\Documents and Settings\All Users\Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data 

Windows Vista:
C:\Users\Public\Documents\Avenza\Geographic Imager\User Guide, Tutorial & Data

Mac OS X
/Applications/Avenza/Geographic Imager/User Guide, Tutorial & Data
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Open Images
1. In Adobe Photoshop, choose File > Open. Browse to the folder location of the images and open the files 

EuropeLL.tif and EuropeTR.tif.

2. Make the EuropeTR.tif file the active document and view the Geographic Imager palette. If the panel is not 
visible, choose File > Automate > Geographic Imager: Show Panel.

3. Keep these images open for the next exercise.

Specify a Reference File

A reference file contains coordinates that describes the location, image and pixel size, and rotation of an image file 
(such as a GeoTIFF). It does not contain actual image data.

1. With the EuropeTR.tif file the active document, click the Reference File Specify... link in the Geographic Imager 
palette. This specifies a reference file containing geographic coordinate information for the active image. 

2. Select EuropeTRref.tfw and click the Open button. Once opened, it will be listed in the Geographic Imager palette 
as the reference file.

3. Keep these images open for the next exercise.

Tutorial Exercises
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Specify a Coordinate System

Some reference files do not store coordinate system information. Using a world file as a reference file requires that 
a  source coordinate system be specified. For more information on reference files, see Chapter 2 in the Geographic 
Imager User Guide.

1. With the EuropeTR.tif file still the active document, click the Specify... link to set the Coordinate System in the 
Geographic Imager palette.

2. In the Specify Coordinate System dialog box, click the Browse button.
3. Expand the Coordinate Systems > Geodetic > World category, select WGS84 Coordinate System and click OK.

4. Click OK in the Specify Coordinate System dialog box to finalize the selection. This assigns the WGS84 
Coordinate System to the active image.

5. Keep these images open for the next exercise.
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Transform a Coordinate System

Transforming a coordinate system creates a destination georeferenced image in a different coordinate system from 
a geographically referenced source image. In this exercise, the image will be transformed from WGS 84 Coordinate 
System to British National Grid coordinate system.

1. With EuropeTR.tif still the active document, click the Transform button in the Geographic Imager palette.
2. In the Transform dialog box, click the Browse button to select a destination coordinate system. This is different 

than specifying a source coordinate system. A destination coordinate system is the coordinate system of the 
image after it is transformed.

3. Expand the Coordinate Systems > Projected > Europe > United Kingdom category, select the British National Grid 
coordinate system and click OK. 
This sets the coordinate system that will be used during the transformation. At this point, Geographic Imager 
automatically selects an appropriate datum shift to be performed during the transformation process. If this 
datum shift needs to be changed, click the Specify button to open the Specify Datum Shift dialog box and select 
the desired datum. See page Geographic Imager user guide for an explanation of datum shift.

4. Change the Pixel Size to 1234.8, leave the other options as the defaults. 
The pixel size can be changed to any user specified value. This essentially changes the size of the image as each 
pixel represents a geographic unit. In this instance, the value was chosen to be near the original value.

5. Now click the Transform button in the Transform dialog box. The image will be transformed.

    

6. Make the EuropeLL.tif file the active document and click the Transform button.
7. Click the Same As option and select EuropeTR.tif (British National Grid) from the Same As drop-down list.
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8.  Click Yes when prompted to update the pixel dimensions to match the selected document (e.g. for the purpose 
of mosaicking). Do not check the Always use the current selection check box.

9. Click the Transform button in the Transform dialog box to confirm these settings. The image will be transformed 
into the British National Grid coordinate system. 

10. Both images are now in the same projected coordinate system (British National Grid).

   

11. Close all images without saving before proceeding to the next exercise.
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Mosaic Images

In these exercises, several images will be mosaicked together, transformed as one image, and exported as multiple 
image tiles.

1. In Adobe Photoshop, choose File > Open. Open the EuropeTL.tif, EuropeLL.tif and EuropeLR.tif and EuropeTR.tif files.
2. Make the EuropeTR.tif file the active document, click the Reference File Specify... link in the Geographic Imager 

palette, and choose EuropeTRref.tfw as the reference file. 
3. Specify the coordinate system as WGS 84. Click the Coordinate System Specify... link in the Geographic Imager 

palette and select one of the other images in the Same As drop-down list. 

4. Make the EuropeTL.tif the active document and click the Mosaic button. Notice that it is in the British National Grid 
coordinate system. This will be the destination document, other images will be mosaicked and transformed into 
this document

Images can have different coordinate systems, different pixel sizes or contain rotation and still be mosaicked. The 
images will inherit the coordinate system and pixel size of the destination document.

Note: Transformations during mosaic are not supported when the destination document contains rotation. To 
mosaic into a destination document containing rotation the images to be mosaicked must be have the same 
coordinate system, pixel size and rotation angle.

5. A list of available documents for mosaicking are displayed in the Available Documents list of the Mosaic dialog 
box. Click the Select All button to select all available images and click the double right arrow button to move 
them into the Selected Documents list. 
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The Advanced Transformation Options here are the same as the Transform dialog box. Use these options to 
resample the layers, set strip size and leave the layers intact or merge them.

The default Layers option is set to Leave intact. This will leave the layer structure intact. The layer structure will not 
be needed for the next exercise so change this option to Merge raster layers. This will merge all the layers together.

6. Click OK to close the dialog box. 
The resultant image is mosaicked in the EuropeTL.tif document window with a coordinate system of British National Grid.

7. To flatten the image, choose Layer > Flatten Image.
8. Keep EuropeTL.tif open for the next exercise and close the other open documents.
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Tile Images
1. With the mosaicked image the active document, click the Tile button in the Geographic Imager palette. 

2. In the Tile dialog box, select the By Number of Tiles option, and type 3 into both the Horizontal and Vertical 
text boxes. This will result in the creation of nine new images.

3. In the Overlap frame, type 100 into both Horizontal and Vertical text boxes. Ensure Pixels is chosen in the 
Units drop-down list. This will result in each image having a 100 pixel overlap with each of its adjacent 
images.

4. In the Destination section, provide a path to a location (directory) where the tiled images will be saved. 
This path can be the default Tutorial data working path.

5. In the Naming drop-down list, select Separate Row/Column Numbers. Each image will contain the name of the 
original image plus a reference to the row and column to which it represents.

6. Select GeoTIFF files from the, Reference File Format drop-down list and click OK.

7. When the process has completed, navigate to the destination directory and view the images. The naming 
format displays its order. For example, the tile EuropeTL_1_1.tif belongs in the first row and first column; 
EuropeTL_1_2.tif in the first row and second column; and EuropeTL_1_3.tif in the first row and third 
column.

8. Close all open images without saving.
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Quick Georeference

Quick Georeference is a fast method to georeference an image. This method requires two conditions as follows:

•	 The image is not rotated (image aligned to True North).
•	 Only two points are needed to georeference, however these points must not contain the same coordinate 

in either the X or Y pixel or world unit (i.e. two points cannot be aligned on the same X or Y axis on either the 
image or world system).

1. In Adobe Photoshop, open EuropeTR.tif. The image is not rotated and is aligned to True North.
2. In the Geographic Imager palette options menu, click Preferences.
3. Uncheck the Use interal referencing referencing format if available check box and click OK.

4. In the Geographic Imager palette, click the Georeference button. 
5. In the Georeference dialog box, click the Add Points button twice. In the table below, type the coordinates of two 

points located at the Northeast and Southwest corners of the image.

Southwest point (Point 2)
X pixel = 0, Y pixel = 452
X world = -2.888, Y world = 54.977

Northeast point (Point 1)
X pixel = 419, Y pixel = 0
X world = 1.766, Y world = 60
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6. Click the Quick Georeference button and select the option By two points (True North only).

7. The image is now georeferenced and two additional reference points are added. Leave the Mode option as 
Standard mode and click OK.

8. Specify the coordinate system to WGS84 Coordiate System.
9. Transform the image to British Nation Grid. Leave the other options as default.
10. Keep this image open for the next exercise.
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Convert to GeoTIFF
1. With the EuropeTR.tif file as the active document, open the Geographic Imager palette options menu and select 

Convert to GeoTIFF. The panel options menu button is located at the top-right corner of the panel. 
2. In the Convert dialog box, specify the name and location for the GeoTIFF. Specify the name of the image as 

EuropeTRCrop.tif and click Save. Now the reference file for the image has been changed to reflect the newly created 
reference file.

3. Keep this image open for the next exercise.

Geocrop
1. With the EuropeTRCrop.tif file as the active document, click the GeoCrop button in the Geographic 

Imager palette.
2. In the GeoCrop dialog box, click the Geodetic option in the Top-left corner frame. The Bottom-right corner frame 

automatically chooses Geodetic because the setting to use same units for both corners is checked. Type in the 
following values:

Top-left corner  Bottom-right corner
X: -2.766 deg  X: -1.655 deg
Y: 56.094 deg  Y: 55.229 deg

3. Leave the coordinate format as Decimal Degrees (D+[*.d]). In the Options frame, leave the option as Round to 
closest and click OK.

4. Select File > Save to save the image. The cropped image and new extents along with the georeference 
information will be saved.

5. Close the image file.
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Marquee Crop
1. Open the EuropeLL.tif file and select the Crop Tool from the Photoshop Tools panel.
2. Draw a rectangular marquee near the centre of the image to define the extents of the post-cropped image.
3. Press the Enter key on your keyboard to complete the crop.

      

4. Choose File > Save As to save the image. Specify a location and file name. The cropped image and new extents 
along with the georeference information will be saved.

Run Scripts
1. Ensure that all images are closed.
2. Choose File > Scripts > Browse.
3. Locate the ScriptBatchProcessingExample.jsx in the following locations:

Windows: ..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts
Mac: /Applications/Avenza/Geographic Imager/Geographic Imager Plug-In/Sample Scripts

4. In the Load dialog box, select the file and click Load.
Watch how the script opens all four tutorial images, sets the source coordinate system, transforms to the British 
National Grid coordinate system and then rotates the canvas 45 degrees.

5. Click the Mosaic button, select all images and click OK.
6. Close all images without saving.

Congratulations, you have completed the Geographic Imager Tutorial Guide. For more in-depth information on 
Geographic Imager tools and features, see the Geographic Imager Supplement Guide and User Guide.
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Adobe Photoshop Tutorial Exercises

The following tutorial exercises use existing Adobe Photoshop functions to manipulate spatial imagery to create 
affects such as shaded relief, colour ramps, 3D  elevation models, false-colour composite and pan sharpened 
images. In addition, learn how to record measurements with the Ruler Tool, resample and sharpen images, convert 
16-bit imagery to 8-bit imagery and select specific water area features..

These tutorial exercises differ from the previous set of exercises because they mainly involve the use of Adobe
Photoshop tools, functions and filters. Paired with Geographic Imager allowing non-native formats such as DEM 
files, MrSID, ECW and JPEG 2000 to be imported streamlines cartographic work flow.

These exercises are only examples of what Geographic Imager for Adobe Photoshop is able to do. Combined with 
creative uses of both sets of tools, a wide range of image manipulation techniques are achievable.
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Generate Shaded Relief

Creating shaded relief has always been a popular cartographic effect. Many cartographers have used Adobe 
Photoshop to achieve this. Using Geographic Imager, common digital elevation model (DEM) formats are now 
supported in Adobe Photoshop, making the process of working with DEMs much more streamlined. This exercise 
explains the steps needed to create a shaded relief effect using a DEM and exporting it as a georeferenced image.

1. In Adobe Photoshop, open Rocky Mountains.dem from the User Guide, Tutorial & Data\Tutorial Data\Rocky Mountain 
3D Landscape Data folder.

2. Chose File > Scripts > Browse and navigate to the following location:
Windows: ..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts
Mac: /Applications/Avenza/Geographic Imager/Geographic Imager Plug-In/Sample Scripts

3. Choose the Shaded Relief.jsx script and click OK. This script is provided can be used on any DEM to create the shaded 
relief effect.

Note: Due to an Adobe Photoshop limitation, the Lighting Effects filter only works on 8-bit images.  
Geographic Imager opens DEM files as grayscale, 16-bit images. Converting the files to 8-bit incurrs data loss in 
height resolution, it is recommended to add lighting effects as the last step of a worksflow.

This is what the script does:
•	 The image is converted to an 8-bit RGB image. This mode is needed to apply the lighting effects used later.
•	 The image is then selected and copied to the clipboard.
•	 An alpha channel (Alpha 1) is created, filled with the colour white and the selection is copied to the alpha channel.
•	 A new layer called Bump Map is created with the blend mode set to Overlay and filled with the color white.
•	 The Filter > Render > Lighting Effects filter is then applied to the Bump Map layer. These lighting effects create 

shadows and highlights that represent shaded relief.
Experiment with lighting effect settings. Choose Filter > Render > Lighting Effects to open the filter settings dialog 
box. These settings were generated by the script and can be used as a starting point. Notice that the script set a 
northwest light source. Please note that the Texture Channel must be set to the alpha channel (Alpha 1) created 
with the original image. Click OK to apply these custom lighting effects. The lighting effects can be applied multiple 
times for increased contrast.

4. Save the image in a format compatible with GIS software (such as a TIFF). Leave it open for the next exercise.
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Note: Geographic Imager 2.5 cannot save to DEM formats at this time, therefore you will be prompted to save the 
georeferencing in one of the supported formats (GeoTIFF, TFW, TAB, etc).

Create a Colour Ramp

After completing the steps in the Shaded Relief Effect exercise, apply a gradient that will represent elevation levels. 
Adobe Photoshop provides excellent support for creating, customizing and editing gradients. Avenza has provided 
some gradients that can be used for colour ramps. This exercise explains the steps needed to apply a colour ramp to 
a DEM.

1. Open or continue with the image saved from the Generate Shaded Relief exercise.

2. Ensure the Options toolbar is visible (if not, choose Window > Options).
3. Click the Gradient tool and open the Adjustments panel. 
4. In the Adjustments panel, double-click the colour ramp. This opens the Gradient Editor dialog box.
5. Click the Load button, navigate to the Geographic Imager Tutorial folder and load Colour Ramp Examples.grd. 

Gradients are added to the Preset section. Hover over the gradients to see their names (Elevation 1 to 7). Click 
OK to close the Gradient Editor.

     

Note: The gradient maps provided are all using equally spaced colour ranges. 
To better depict some ares of a DEM, irregular colour ranges might gave a better result.

Note: The image histogram (choose Window > Histogram) illustrates the distribution of pixels per color intensity 
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level, which is directly related to the DEM height distribution. It can be used as a guide to construct colour 
maps adapted to the DEM.

6. In the Layers panel, select Layer 0 so the gradient map will only be applied to this layer.
7. Create a new gradient map adjustment layer by choosing Layer > New Adjustment Layer > Gradient Map. 

Name the layer Colour Ramp and leave the Blending Mode as Normal. An adjustment layer with the default 
gradient is created.
The advantage of creating the gradient on the adjustment layer is that it can be edited (multiple times) without 
affecting the original image.

Note: Setting the Blending Mode to Difference will prominently display the difference in elevations. This mode 
compares the difference between pixel values; large differences lighten the colour and small differences 
darken the colour. This will alter the colour ramp so it is best used for display purposes only. It can be used as 
an indictor that the colour ramp displays the elevation differences in the detail required.

8. Open the Adjustment panel displaying the gradient and click the drop-down list to display the available gradients. 
Select any gradient to apply it to the image. Experiment with these gradients or create your own.

9. Close  all images without saving.
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Create a 3D Elevation Model with an Orthographic Texture

Note: This tutorial requires an installed video card that supports OpenGL to use the 3D functionality of Adobe Photoshop. 
Choose Edit > Preferences > Performance to see if your video card supports it. GPU settings are enabled if supported.

How to run the script using the sample data:

1. In Adobe Photoshop, choose File > Scripts > Browse and navigate to the following locations:
Windows: ..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts
Mac: /Applications/Avenza/Geographic Imager/Geographic Imager Plug-In/Sample Scripts

2. Select the Rocky Mountains.jsx script and click Load.
3. The script will run and perform the following tasks automatically:

•	 Open a DEM
•	 Create a 3D plane from the data
•	 Modify the vertical exaggeration of the 3D scale
•	 Position the 3D model
•	 Load and drape a texture image (ortho image) on the 3D model
•	 Set the final 3D model position
•	 Modify Canvas size for final output
•	 Add a new layer and draw a gradient to represent the sky

4. When creating a 3D representation, georeferencing is not maintained. Click OK to close both warnings.

   

5. The 3D elevation model is now ready for the final output.

For an additional effect, the 3D elevation model can be viewed in stereoscopic 3D.

1. In Adobe Photoshop, choose 3D > Render Settings.
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2. In the 3D Render Settings dialog box, check the option for Stereo type.
3. If viewing the image using classic red-blue glasses, specify the Stereo type to Red/Blue. If using a lenticular lens 

select Vertical Interlaced.
4. Set the Parallax to 80. Parallax adjusts the distance between the two stereo cameras. A higher value increases 

the three-dimensional depth but reduces the depth of field, making items ahead or behind the focal plane 
appear out of focus. 

5. The Focal Plane determines the position of the focal plane relative to the center of the image bounding box. 
Negative values move the plane forward and positive values move it backward. Leave the Focal Plane at its 
default of 0.

6. Click OK to complete the 3D render settings.

Modify the Rocky Mountains.jsx elevation model script to accommodate user data. To perform this tutorial with data 



21Geographic Imager 2.5 Tutorial Guide

other that the sample data, the following parameters need to be satisfied:

•	 A DEM and texture image are needed of the same area to create one 3D model
•	 One of the images should be transformed to match the other images size, pixel size, and coordinate system
•	 The script needs to be modified to reflect the location of the images.

1. In the operating system file browser, go to the following location:
Windows: ..\User Guide, Tutorial & Data\Tutorial Data\Sample Scripts
Mac: /Applications/Avenza/Geographic Imager/Geographic Imager Plug-In/Sample Scripts

2. Open the Rocky Mountains.jsx script in a text editor.
3. At the beginning of the script, there are two paths that need to be modified to enable this script to be used with 

custom data. Modify the appropriate paths depending on the operating system (Windows or Mac).
•	 Modify the first path (yourPath) to specify the location of the elevation model (DEM, DTED)
•	 Modify the second path (yourPath2) to specify the location of the texture or image to be draped over the 

elevation model

4. Once the correct paths are modified, save the script using a different file name. Run the saved script by 
choosing File > Scripts > Browse. Find the location of the saved scripts and click Load.

5. Review your image and make adjustments to the script as necessary.
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The Ruler Tool

Analysis tools can be used to record and export measurements with georeferenced images. These tools were 
originally introduced in Adobe Photoshop CS3 and were designed for the medical community. They also serve as 
valuable tools for cartographers.

1. In Adobe Photoshop, choose File > Open and browse to the Landsat 7 Multispectral folder and open Band 8 
(Panchromatic), 15 meters.tif.
This is an image of downtown Toronto circa 2004. The projected coordinate system is NAD 83 UTM Zone 17N in 
meters. The Geographic Imager palette displays the pixel size. A precise measurement is dependent on the pixel 
size. For this example, 1 pixel is equal to 15 x 15 meters and provides a moderately accurate measurement.

Note: Modifying the pixel dimension ratio to a non-square pixel will not record correct measurements using the 
measurement tools. This can be rectified by using the Geographic Imager Transform function and changing 
the pixel options and selecting keep pixels square.

2. From the Analysis menu, choose Set Measurement Scale > Custom.
3. In the Measurement Scale dialog box. Set the Logical Length to 15.
Note: Up to four decimal places can be entered in the custom field to provide enough accuracy for all images.

4. Type the Logical Units as meters. 
The Logical Unit field is used to store what unit the pixel size is in. A custom preset measurement scale is useful 
when using images with the same pixel size.

5. Click OK to close the dialog box.
6. Before measuring, choose Window > Measurement Log to open the Measurement Log panel. The panel appears 

either as floating or docked at the bottom of the screen.
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7. In the Adobe Photoshop Tools panel, select the Ruler Tool (sixth tool from the top—if not showing, click 
and hold the button to display the flyout menu). It is also accessible by choosing Analysis > Ruler Tool.

8. Take a measurement of a section of the most famous street in Toronto, Yonge St. As shown in the screenshot, 
click a start point at the Yonge and Bloor St. intersection and drag the Ruler Tool down to Front Street and click 
the mouse again. A measurement line is drawn on the image.

9. In the Measurement Log panel, click Record Measurement.
The distance recorded of Yonge St is approximately 2720 meters (Length column). This is very close to the actual 
distance of 2.724 km.

The Ruler Tool is not the only tool used to record measurement. Use the Lasso, Magic Wand and Quick Select tools 
to select an area and click the Record Measurement button to record it to the Measurement Log. All measurements 
can be exported to a tab delimited Unicode text file (select the desired rows and click the export button in the up-
per right corner of the Measurement Log panel.

10. Close the image without saving.
Note: Remember the resolution of the image will reflect how accurate the measurements will be. Analysis tools can 

not be used with non-square pixels because a correct scale can not be determined for each pixel.
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Create a False-Colour Composite

Another powerful remote sensing tool in Adobe Photoshop is the ability to create a false-colour composite image. 
Multispectral images contain information outside the visible electromagnetic spectrum. To use this information, the 
wavelengths outside the visible spectrum need to be reassigned to the visible spectrum so that it is visible to the 
human eye. This tutorial will create a false-colour composite of downtown Toronto and surrounding suburban areas.

Often multispectral satellite images will consist of several greyscale images, with each image containing one of the 
wavelengths or bands of the electromagnetic spectrum. These images need to be combined into one image. The 
Adobe Photoshop function called Merge Channels merges images to create false-colour or true-color composites. 
Easily identify distinct features by their unique spectral signature.

1. In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:
•	 Band 2 (Green), 30 meters.tif
•	 Band 3 (Red), 30 meters.tif
•	 Band 4 (Near Infrared), 30 meters.tif

Note: When creating false-colour composites, images must be of the same image resolution and have the same 
spatial extents. If the images need to be cropped, it is recommended to use the Geographic Imager GeoCrop 
function to assure that the extents of the images remain consistent.

2. From the Windows menu, choose Channels to open the Channels panel. 
3. In any active document window, click Merge Channels from the Channels panel options menu.

4. In the Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.
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5. In the Merge RGB Channels dialog box specify the following channels:
•	 Red: Band 4 (Near Infrared), 30 meters.tif
•	 Green: Band 3 (Red), 30 meters.tif
•	 Blue: Band 2 (Green), 30 meters.tif

6. Click OK to complete the merge.
Note: A reference file is created in the format specified by the Geographic Imager Preferences dialog box.

Notice that the Geographic Imager palette shows that the merged image does not have any coordinate information.

A false-colour composite image with georeferencing has been created. The band combination chosen makes 
vegetation appear in shades of red because vegetation reflects a lot of near infrared light. The brighter the red, the 
healthier the vegetation. Urban areas appear blue-grey. The bright red areas at the top of the image belong to the 
prestigious Rosedale Golf Club.

7. Close any open images.
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More about Landsat 7 band combinations

R,G,B Description

3,2,1 The “nature colour” combination. It provides the most water penetration.

4,3,2 Standard “false-colour” combination. Vegetation shows in red.

7,4,2 The “nature-like” combination. Sand, soil and minerals show in multitude of colour. Fires would appear in 
red. It provides clear imagery in desert region.

7,5,3 The “nature-like” combination. Sand, soil and minerals appear in variety of colour.

5,4,1 Good for agricultural studies. Healthy vegetation shows in bright green colour.

7,5,4 Provides best atmospheric penetration. Vegetation shows in blue. Useful for geological study.

7,3,1 Rocks may appear in variety of colour. Good for the geological study.

Note: Some multispectral images may be provided as a single image that stores extra channels (called alpha chan-
nels in Adobe Photoshop). To create false-colour composites from these images in Adobe Photoshop, the 
channels must first be split into single gray scale images (Channels panel option menu > Split Channels). Then 
channels can be merged and reordered as described above.

Pan Sharpen

Another useful tool Adobe Photoshop provides is the ability to intelligently resample images. Pan sharpening (short 
for panchromatic sharpening) a single band is used to increase the spatial resolution of a multispectral image. A 
multispectral image contains a higher spectral resolution of a panchromatic image, while often a panchromatic im-
age will have a higher spatial resolution than of a multispectral image. A pan sharpened image represents the best 
of both worlds which is essentially a sensor fusion which gives a multispectral image with a higher spatial resolution.

1. In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:
•	 Band 8 (Panchromatic), 15 meters.tif
•	 Band 1 (Blue-green), 30 meters.tif
•	 Band 2 (Green), 30 meters.tif
•	 Band 3 (Red), 30 meters.tif

In this exercise, the panchromatic image will be combined with a multispectral image in true colour however any 
false-colour composite combination can be used. 

2. From the Windows menu, choose Channels to open the Channels panel. 
3. In any 30 meter resolution active document window (Band 1, 2 or 3), click Merge Channels from the Channels 

panel options menu.
Note: If Band 8 is chosen, Merge Channels will be disabled.
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4. In the Merge Channels dialog box, select RGB Color in the Mode drop-down list and click OK.
5. In the Merge RGB Channels dialog box specify the following channels:

•	 Red: Band 3 (Red), 30 meters.tif
•	 Green: Band 2 (Green), 30 meters.tif
•	 Blue: Band 1 (Blue-green), 30 meters.tif

6. Click OK to complete the merge.

Since the merged image is at 30 meter resolution, it is necessary to resample it to match the resolution of the 
panchromatic image (15 meter resolution).

7. With the merged document window active, choose Image > Image Size.
8. Ensure Constrain Proportions and Resample Image check boxes are checked. Select Bicubic (best for smooth 

gradients) as the resampling method.
9. In the Pixel Dimensions frame, select percent from the units drop-down list.
10. Enter 200 in the width dimension (height automatically changes to 200 due to constrain proportions) and click 

OK to complete image scaling.
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11. Under the Image menu, choose Mode > Lab Color.
12. In the Channels panel options menu, click Split Channels.
13. The merged image is split into three images: Lightness, a and b.

Each image with have an “_l”, “_a”, or ,”_b” appended to the end of the document name. The a and b channels 
carry colour information and the idea is to substitute the panchromatic image for the Lightness channel.

The following step involves some trial and error. The outcome is to make the image brightness and contrast match 
the Lightness channel as much as possible. Ignore areas of water or vegetation and concentrate on roads and 
buildings. Often panchromatic images contain data that extends into the infrared therefore vegetation and areas of 
water appear differently. The higher resolution of the panchromatic image, the more contrast it will appear to have.

14. Make Band 8 (panchromatic), 15 meters.tif active and adjust contrast, brightness, or level adjustments using Adobe 
Photoshop Adjustment Layers (Layers > New Adjustments Layer).

Note: Ignore vegetation and areas of water because panchromatic images often contain near infrared data.

15. If adjustment layers were used, choose Layer > Flatten Image.
16. In the Channels panel options menu, click Merge Channels.
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17. In the Merge Channels dialog box, select Lab Color in the Mode drop-down list and click OK.

18. In the Merge Lab Channels dialog box specify the following channels:
•	 Lightness: Band 8 (Panchromatic), 15 meters.tif
•	 a: Untitled-1_a
•	 b: Untitled-1_b

Note: The Untitled documents were created from splitting the channels in step 14. Untitled documents may not be 
appended with 1 however be sure that the final character corresponds to the channel e.g. a = “Untitled-4_a”.

19. Click OK to complete the merge.Convert the image to RGB mode and leave the image open for the next exercise.

Note: This exercise is a guide to enhance images for display or printing purposes, this method involves subjec-
tive judgment to pixel colour adjustments and should not be used for scientific purposes. The colours of 
the pan-sharpened image will look different from the original RGB image because panchromatic data (from 
Landsat 7) extents into the infrared, most notably vegetation and areas of water.
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Resample and Sharpen

Adobe Photoshop sharpen filters can increase the detail of the image. The Sharpen filter menu has a variety of 
sharpening tools. These tools also involve some trial and error to achieve enough sharpening without overdoing it. 
Two sharpening filters are explained below.

The Unsharp Mask 

This filter sharpens an image by increasing contrast along the edges of an image. It locates pixels that differ in value 
from the surrounding pixels, this option can be modified by changing the threshold. The radius of the region to 
which each pixel is compared is also an option that can be modified.

Smart Sharpen

This filter has more advanced controls not available in the Unsharp Mask filter. This filter will allow control over the 
amount of sharpening that occurs in shadow and highlight areas. The document should be viewed at 100% to get 
an accurate view of the sharpening.

•	 Amount: Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the 
appearance of greater sharpness.

•	 Radius: Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater 
the radius value, the wider the edge effects and the more obvious the sharpening.

•	 Remove: Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the 
Unsharp Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail 
and reduced sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject 
movement. Set the Angle control if you choose Motion Blur.

•	 Angle: Sets the direction of motion for the Motion Blur option of the Remove control.
•	 More Accurate: Processes the file more slowly for a more accurate removal of blurring.

In the Smart Sharpen dialog box, click the Advanced option to display the Shadow and Highlight tabs. Adjust sharp-
ening of dark and light areas using these tabs. If the dark or light sharpening halos appear too strong, reduce them 
with these controls, which are only available for 8-bits and 16-bits-per-channel images:

•	 Fade Amount: Adjusts the amount of sharpening in the highlights or shadows.
•	 Tonal Width: Controls the range of tones in the shadows or highlights that are modified. Move the slider to the 

left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the 
darker regions for shadow correction and only the lighter regions for highlight correction.

•	 Radius: Controls the size of the area around each pixel that is used to determine whether a pixel is in the 
shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies 
a larger area.
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1.  With the image still open from the previous exercise, choose Filter > Sharpen > Smart Sharpen.
2. Set the following parameters in the Smart Sharpen dialog box:

•	 Set the Amount to 15%
•	 Set the Radius to 2.0 pixels
•	 Set Remove to Lens Blur
•	 Check the More Accurate checkbox

3. Click OK.
Features appear to have more detail when compared to the image prior to sharpening. Again, this will involve some 
trial and error if the results are not satisfactory, experiment with settings if more sharpening is needed.
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Convert 16-bit Imagery to 8-bit

QuickBird imagery has a dynamic range of 11-bits per channel, in a 16-bit file. Adobe Photoshop can open 16-bit 
imagery, however, some images need to be converted to 8-bits per channel before any processing can be done. 
When opening an image it will appear to be completely black. The following steps will alter colour information 
therefore save a copy if the original image information will be needed for other applications.

Option 1

1.  Open a 16-bit image that needs to be converted.
2. Choose Image > Auto Color.

This will apply the adjustment directly to the image. This method is automatic and discards image information. 
Saving a copy of the image is recommended.

Option 2

1. In the Image menu, choose Adjustments > Levels. 
This adjusts the tonal range and colour balance of an image by adjusting intensity levels of image shadows, 
midtones, and highlights. The histogram displays how pixels in the image are distributed by graphing the 
number of pixels at each colour intensity. An image with detail concentrated in the shadows is called a low-key 
image. This will be the case with most 16-bit images displaying all the information in a small range in the left 
part of the histogram. It is necessary to adjust the tonal range by changing the input range of the levels.

2. In the Levels dialog box, drag the white slider closer to the black slider until the sliders are now in the range of 
the histogram. Check the preview check box to see the effect on the image. The image is now visible.

Note: Values can be directly entered into the Input Levels text boxes.

Note: These options are also available by creating an adjustment layer. Please reference the Adobe Photoshop Help 
for this information.
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Select Water Areas

Some DEM files contain water areas (usually at a zero height). Users may want to represent these areas as a single 
color while using a gradient map or sun-illumination on the actual relief information.

To achieve this with Adobe Photoshop functions, the water areas have to be selected and moved to a separate layer 
prior to applying colour maps or lighting effects (as explained earlier in this tutorial guide). The selection of water 
areas is done using Adobe Photoshop Select > Color Range, which selects pixels by their pixel value or range.

Note: More advanced function to allow selection per DEM height value or range are planned for the next release of 
Geographic Imager.

1. In Adobe Photoshop, browse to the Tutorial data folder and open Yukon Water.dem.

2. Choose Select > Color Range.
The color range command selects a specified color or color range.

3. In the Color Range dialog box, choose Sample Colors from the Select drop-down list.

4. Position the eyedropper pointer over the image or the preview area and click on water areas to sample the 
colour. Notice how the preview area changes.
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5. Set the Fuzziness to 0. This will force it to only select the sampled color (increase the fuzziness to select a wider 
range of colours).

Note: The preview displayed in the Color Range dialog box is based on an 8-bit image, the actual selection on a 
16-bit image may be different from the preview.

6. Click OK to perform the selection.
7. To create a new layer from the selection, choose Layer > New > Layer via Cut.

     

Water areas and elevation data are now in separate layers. The water layer can be filled with a light blue color while 
a gradient map can be applied to the elevation data.

Congratulations, you have completed the Geographic Imager Supplemental Tutorial Guide. For more in-depth 
information on Geographic Imager tools and features, see the Geographic Imager User Guide.
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